User:Gerp

The Beyond Skyrim Wiki — Hosted by UESP
Jump to: navigation, search

Hi, I'm Gerp. I'm a beginner 3D student in the Arcane University programme.

Here's a guide to converting a Blender mesh to a Skyrim Special Edition NIF:


Blender to Skyrim SE NIF[edit]

Do not try to export directly to a NIF from Blender. Instead, we will export to an FBX file, convert it to a NIF, and then adjust it.

If you get stuck, find me in the Arcane University's Discord server and ask for help. :)

Requirements[edit]

This is for Windows only.

Download any of these that you do not already have, and unzip the .zip and .7z files (use 7-Zip for .7z):

If you want to verify that your conversion worked (recommended), you also need to install these:

  • Skyrim Special Edition
  • Skyrim CreationKit

Steps[edit]

These are based on this video. If you want, you can use that instead, check here when you run into issues, and then skip to Verification below at the end.

  1. Make or open your object in Blender, optionally with a colour texture and/or normal map
  2. If you have a colour texture:
    1. Open it in Paint.Net
    2. Resize it so the height and weight are multiples of 2 (example: 4096x4096 is OK, but 6144x6144 is not)
    3. Export it to a DDS file with BC1 compression in a folder called "textures" next to the .blend file
  3. If you have a normal map:
    1. Open it in Paint.Net
    2. Resize it so the height and weight are multiples of 2 (example: 4096x4096 is OK, but 6144x6144 is not)
    3. Export it to a DDS file with BC7/DX11+ compression in a folder called "textures" next to the .blend file
  4. Ensure that the Blender unit scale is 1.0 and the object is the desired size in your preferred unit system
    Blender scene units.png
  5. Duplicate the object in Blender with Shift+D and then right click to prevent moving it
  6. Scale the new object in Blender 100x
  7. Apply all transforms on the large object in Blender by pressing Ctrl+A with the object selected and clicking All Transforms
  8. With the large object selected in Blender, click File > Export > FBX (.fbx)
  9. In the pane that appears, on the right side, set these options:
    Blender export fbx skyrim settings.png
  10. At the bottom of the pane, click the Export FBX button
  11. Open the Windows command line by pressing Windows+R and entering: cmd
  12. In the command line window, go to the folder with ck-cmd.exe by entering: cd <folder path>
    • Example: cd C:\Users\gerp\Downloads\CK-CMD
  13. On the command line, enter: ck-cmd importfbx <FBX file path> -e <FBX folder path>
    • Example: ck-cmd importfbx "C:\Users\gerp\3D Models\myobject.fbx" -e "C:\Users\gerp\3D Models"
    • This converts the FBX to NIF
  14. If you have a colour texture and/or normal map:
    1. Open the NIF in NifSkope
    2. In the top-left panel, open all hierarchy trees, and click the BSShaderTextureSet entry
      Nifskope textures.png
    3. In the bottom panel, open the hierarchy tree
      • If you have a colour texture:
        1. Double click the value column in the first row of the tree, and ensure that it is textures\<colour texture name>.dds
        2. Save the file, and click Yes or OK if any dialog box appears
      • If you have a normal map:
        1. Double click the value column in the second row of the tree, and ensure that it is textures\<normal map name>.dds
        2. Save the file, and click Yes or OK if any dialog box appears
    • Note: you should now be able to see your textures on the mesh
  15. Open NIFUtilsSuite
  16. If you have not used the .exe file before, it will ask you for settings. In the first screen, add the files below. For the later screens, just use the defaults
    • NIF.XML: nif.xml from Requirements above
    • Textures: your Skyrim Data\textures folder (example: mine is G:\SteamLibrary\steamapps\common\Skyrim Special Edition\Data\textures)
    • Templates: the folder with either of the Skyrim_X.nif files from Requirements above
    • Default Input: wherever you generally want to put your NIFs
    • Default Output: same as Default Input
    • NifSkope: NifSkope.exe
  17. Click the Chunk Merge tab
  18. In the Files > Target-File and Collision-File fields, open your NIF
  19. In the Files > Template field, select Skyrim_Static.nif for an immovable object or Skyrim_Clutter.nif for a movable one
  20. In Collision Source, select Mesh data
  21. In Collision Material, select from the dropdown a type of visual and sound effects for your object colliding with things in game
  22. Click the Add Collision button
    • Note: if it crashes, try making and using a simple bounding box for the Collision Source by adding a cube mesh in Blender, transforming it in Object Mode to barely contain your 100x-scale mesh, applying the transforms with Ctrl+A > All Transforms, and exporting it to FBX and converting it to NIF as above
  23. Copy the NIF to the same folder as SSE NIF Optimizer.exe
  24. Open SSE NIF Optimizer, and click the Optimize button
  25. In NifSkope, open the NIF in the Optimizer folder
    • Note: the textures do not appear here. This is OK :)
    • Note: if you click the red Show Collision icon button, you should see your collision wireframe in red
  26. Right click the mesh, and click Mesh > Update Bounds. If a dialog box appears, click Yes
  27. Save the file. If a dialog box appears, click Yes or OK
  28. Copy the NIF from the Optimizer folder to your Skyrim Data\Meshes folder (example: mine is G:\SteamLibrary\steamapps\common\Skyrim Special Edition\Data\Meshes)
  29. If your mesh has textures, copy those DDS files to your Skyrim Data\textures folder

Verification[edit]

If you want to see if it worked:

  1. Open CreationKit
  2. Click File > Data
  3. Double-click Skyrim
  4. If you already have a mod you want to add to, double-right-click it
  5. Click the OK button
  6. In the left-side list of the Object Window, select a category or subcategory that you think best describes your object
  7. In the right side list of the Object Window, find something roughly similar to your object. Right-click it and click Duplicate
  8. Double-click the duplicated object
  9. At the top of the new window, rename the object to a single word describing your new object
  10. Beside the Model field, click Edit
  11. Beside the Model File Name field, click Edit
  12. Select the NIF in your Skyrim Data\Meshes folder
    • You should see a properly sized and textured version of your mesh
  13. Click the OK button of both windows, and when a dialog box appears, click No then Yes in the next dialog box
  14. In the Cell View, double click UnownedCell
    • A 3D view of the cell should appear. You can zoom with the scroll wheel, rotate around the selected object with Shift, pan with Spacebar, and focus on an object by double-clicking its name in the Cell View or pressing Shift+F for the selected object
  15. Drag your new object from the Object Window to the 3D UnownedCell view
    • You should see your new object. You can move it horizontally by clicking and dragging it, and vertically by holding Z while clicking and dragging
  16. Save your mod by clicking the Save icon button in the top left part of CreationKit
  17. If prompted, enter a name for your mod's file name
  18. Open Skyrim, and click PLAY
  19. In the Skyrim main menu, click MODS, and wait for them to load
  20. Press T and ensure that your mod is selected, then press Esc twice, and click OK if it asks you to restart the game
    • You might also need to disable any mods that prevent you from spawning a new character where you want (example: Random Alternate Start)
  21. In the main menu, press the ~ key, which opens the console
  22. In the console, enter: coc unownedcell
    • This starts the game inside the cell you edited in CreationKit
    • You should now see your model from Blender :)