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INTRO:
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v 3DS MAX NIF IMPORT-EXPORT PLUGIN

As for today (the end of March, 2012), there are no nif
exporters for 3ds Max that can produce working bow files
which you could add straight away into the game. Some
NifSkope’s "magic" is necessary. In a future, this may
likely to change, and while some of the steps described in
this tutorial may become obsolete by then, still the basic
workflow should be quite similar.

PURPOSE OF THIS TUTORIAL:

This tutorial describes how to use a model of created
bow (either created from scratch in 3DS or imported from
elsewhere), and skin it to the armature imported from
original bow files. Then export the skinned mesh, and
finalize it in NifSkope. And add to the game with the help
of Creation Kit.

THINGS YOU SHOULD KNOW BEFORE WE BEGIN:

Bows in Skyrim unlike all melee weapons use bones
for animations. They have simple skeletons and their
meshes are attached to it. So "technically" they have more
in common with armors rather than with a "static" melee
weapon.

WHAT YOU NEED TO FOLLOW THIS TUTORIAL:

v 3DS MAX
(to rig/skin created/imported bow mesh)

v 3DS MAX NIF Import-Export plugin
(to import/export rigged/skinned bow mesh)

v NifSkope
(to setup all settings properly in the nif file)

v BSA Browser
(to extract game’s original files)

v TES V: Creation Kit
(to add model to the game)

v 3DS MAX

I use 3DS MAX 2010 32bit version for this tutorial. In fact
any other version of Max should work while it has proper NIF
Import-Export plugin installed.

The version I use is 3.7.1 and can be downloaded from
here:

http://skyrim.nexusmods.com/downloads/file.php?id=5622

I prefer to use manual versions of these and copy proper
files to Max folder by hand. This always works for me. I tried
installer once and it did nothing useful ;p

I know that this version is not the latest one but it works
good as far as skinning is concerned - it properly imports the
bones, and all additional steps are performed in NifSkope

anyway.

v NIFSKOPE

Currently the latest version is 1.1.0 RC6 and can be
downloaded from here:

http://sourceforge.net/projects/niftools/files/nifskope/1.1.0/
Install it.

v BSA BROWSER

You can download BSA Browser from here:

http://skyrim.nexusmods.com/downloads/file.php?id=1395

v TES V: CREATION KIT

You can download editor from the Steam (should be
somewhere in tools section).

PREPARATIONS:
Now we need to do some things before we begin:

v Make sure you have all these 5 programs/tools
installed.

v Extract these two original BSA archives
somewhere with BSA Browser:

Skyrim - Meshes.bsa
Skyrim - Textures.bsa

I have the content of these files extracted in
E:\SkyrimFiles\Data folder.

v Prepare two files and put them in one folder:
My folder for this is E:\3D\MAX\Import
# First file is the one with your model.

¢ Second file is the file with one of the original bows
from Skyrim. I copied ebonybowskinned.nif file here from
the place to which I extracted original BSA files in
previous step, so the path in my case was like this:
E:\SkyrimFiles\Data\meshes\weapons\ebony



http://skyrim.nexusmods.com/downloads/file.php?id=5622
http://skyrim.nexusmods.com/downloads/file.php?id=1395
http://sourceforge.net/projects/niftools/files/nifskope/1.1.0/
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WORK IN 3DS MAX

v OPEN MAX AND IMPORT THE FILES

Open the scene in MAX with your bow. Or if you
want to import any bow made for Oblivion use these

settings:

General Options:

Game: ’Oblivion

I e

Import:
[ ]ughts
|:| Cameras
D Callision
Furniture Markers
Animation:
[Vl n
Clear Animation
[] Add Key Motes
Add Time Tags

Skeleton:
D Import Skeleton

Remove Unused Bones

e [ ——

Geometry:

Vertex Colors
Skin Maodifier

El Auto Smooth Mesh

[]Remove Tlegal Faces

[ weld vertices 0.01

Miscellaneous:

Flip LY

Render Textures in View
D Ignore User Prop Buffers
E] Ignore Root MNode

[#] Use hiftoals Shader

Lze Biped

D Create w) Dummy Nodes

niftools, sourceforge.net

While importing bows from Oblivion
Collision and Import Skeleton options should be turned off.

Next import one of original bows from Skyrim with
the settings shown on picture above but with two changes:
Import Skeleton option should be checked, and Game in
General Options should be set to Skyrim.

v POSITION YOUR BOW

Use original imported bow’s position as reference and
align your bow correctly. If you import any bow from
Oblivion it will be most likely positioned quite well. It is most
important to have grip of the bow in proper position, the
string is not so important as any offsets aren’t visible in FPP
view at all, and in TPP view all of original bows have
inaccurate animations anyway that make the strings of the
bows to bend closer to the bow than the hand is ;p So this
shouldn’t be fixed by the bow’s shape, but by editing the
actual animation files. After you finish delete original bow.
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v SKINNING THE Bow

Skinning? Sounds cryptic. Anyway that’s the process
of assigning certain values to every vertex of your mesh
which (those values) will determine how the movement of
bones influences the movement of those vertices. Quite
often skinning is referred to as weight painting.

There are various techniques here. Maybe you are
quite proficient at skinning and already have your favorite
method, or maybe you’re reading about this for the first
time ;]

Anyway I’ve found that editing Weight Table works

for me in the case of the bows, so I’ll cover this approach
here.

v Select your bow and add Skin modifier to it from
the Modify tab. Then look at Parameters panel below for
Skin modifier and search for Bones: section and click Add
button there. In Select Bones window, highlight all bones
(CTRL+A) and press Select button.

v In Bones: section highlight Bow MidBone then
press Edit Envelopes button above and mark Vertices
option in Select section there. Then select in Top View all
vertices you want to assign to the middle bone - these parts
of your bow won’t be affected by any deformations as
middle bone is relatively "static".

Bow visible in Top View
window with all vertices of
the grip selected (marked
by those white squares)

After you select the middle part of your bow then
scroll down Skin modifier panel until you spot Weight
Table button. Press it.
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v In Skin Weight Table window change the option at
bottom left corner from All vertices to Selected vertices.
Then from top menu of that window choose Edit -> Select
All.

Now CTRL + Right Click anywhere in the
Bow_MidBone column to set all its values to 1.0, then
SHIFT + Right Click on any other columns to clear their
values.

Edit Vertex Sets Options
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= 3 Use the middle mouse wheel to scroll the window

Skin Weight Table window. You can see the Bow_MidBone column
where all values have been set to 1.0 and other columns where their
values have been deleted.

The look of middle part of the
bow in Top View after edits done
in Skin Weights Table.

All these vertices marked red
have been assigned to middle
bone of the bow’s armature with
the weights of 1.0 each.

The middle bone in not affected
by the animations much, so this
means that all those vertices will
be relatively static in
comparison to other parts of the
bow like its string or ends.
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v Time to skin upper middle section of the bow

You can notice two
groups of vertices at the
picture above. These are
marked in orange.
Bottom one (marked with
white outlines) has
weights set "fifty-fifty"
between Bow_MidBone
and Bow_UpBonel. And
upper group shares
weights equally between
Bow UpBonel and
Bow_UpBone2.

You can set this in a similar way described in a
previous point. First you CTRL+RClick to set 1.0 values in
Bow_MidBone column, then SHIFT+RClick to remove
data from any other columns. And finally double click on
any row in Bow_UpBonel and type 0.5 there then press
Enter. This should make all values for these two columns
equal to 0.5.

v And time to skin upper end of the bow

For all those selected vertices marked with red
squares, all weight values have been set to 1.0 for
Bow_UpBone?2.
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v And finally it’s time for the string... EXPORT FROM 3DS

After you finish to weight vertices of the bow, then
export it with these settings:

Select vertices in the middle of the string of your bow.
And in Skin Weight Table window set values of 0.5 for

weights for Bow_StringBonel and Bow_StringBone2
columns.

Selected middle vertices of string
(in white)

Edit Vertex Sets Options

' I

Ccoov [ Paste Left dick and drag left/right on a cell to change the weight

bones that should affect their movement.

v And of course, do not forget to repeat the process
for bottom parts of your bow. But focus on "Lo" bones
instead.

Values set for every vertex in the middle of the string for both

General Options
Game

Version User User 2

Skyrim

~| 20207 INEEIIEE

Default Texture Prefix:
textures

Export:
[ ] Hidden Nodes
[ | skeleton Only

[ | coliision

Mesh:
[ | senerate Strips
[ | Extra Nodes an Mesh

s
D Vertex Colors
UUpdate Tangent Space
Collapse Transforms
Zero Transforms

Weld Vertices:
Animation
[NIF wio Animation

Transforms

Pririty: 0.0

Scene:

Auto Detect

D Cameras
[]ughts

Skin Modifier
Expart Skin Modifier
Enable Multiple Partitions
Bones Per Partition:

Bones Per Vertex:
Remove Extra Bones
Generate Partition Strips
Miscellaneous:

|:| Add User Prop Buffer

Sort Modes
[]add Accum Nodes
[] start nifskope

Root Mode Type: [ESFadeNode

z

[ Export I ’ Cancel ]

niftools. sourceforge.net
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NIFSKOPE’S MAGIC
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CREATION KIT - OH DEAR...

Very Important Note:

If you work with bows in NifSkope ALWAY'S make
sure that Auto Sanitize before Save option is turned OFF!
(it’s in File menu). Current versions of NifSkope make a
mess with blocks order on save in files that contain data
needed for bows to properly work. If you forget to disable
this option your bow may work well in menu or in your
character’s hands, but if you decide to drop it, don’t be
surprised while it vanishes completely.

Anyway, it makes no sense to reinvent the wheel, so
we will be copying exported bow data onto nif file with
one of original bows:

v Open any original file with the bow from Skyrim
in NifSkope then select and delete only the branch(es) with
its mesh. This will be your final file.

v Open exported file with your bow, then select the
branch with its mesh and copy it to that final file from
where you deleted that original mesh. Close this exported
file.

v In your final file expand NiTriShape branch with
your bow and delete BSLightingShaderProperty sub-
branch from there. Then open one of the stock bows
temporarily, expand NiTriShape branch with its mesh and
copy/paste original BSLightingShaderProperty and assign
it to NiTriShape branch of your bow in final file. Close this
temp file.

v Before you save and close your final file you may
want to change textures in BSShaderTextureSet block
(sub-branch of BSLightingShaderProperty).

You may also want to play with other settings in
NifSkope like BSInvMarker (positions your bow in
inventory). And do not forget to turn off Auto sanitize
option before save!

The least favorite part of all this. At least for me ;p

That shear amount of options and settings for weapons
in CK is tiresome so I only described here the quickest way to
add the bow. Anyway refer to official wiki page in case of any
troubles.

v Expand WorldObjects -> Static -> WEAPONS
branch. Double click 1stPersonDaedricBow entry there to
open its properties. In Static window change ID and path to
your model, hit OK and create new form.

v Go to Item -> Weapon -> WEAPONS -> Daedric
branch and double click on original DaedricBow entry to
open its properties. Change there: ID and Name. Then
switch to Art and Sound tab. Choose the path to your
model, and set 1st Person Model Object to the ID you
created in previous point. Hit OK and create new form.

v Now you may want to drop your bow somewhere
in the world to test it or use the console to add it. Your
choice. I can only hope that your bow will behave properly
since the first time.

Happy bows making! ;]




